Just for a bit of explanation behind why viewers may be broken right now.

Previous versions of KanColle had just one number to define what "version" a ship was on. For example, Mutsuki was on version 19 so the api had ' "api_version" : "19" '. With the latest patch, they broke this one version into three values so Mutsuki's new version is ' "api_version" : ["19", "19", "20"] '. For a lot of viewers/tools expecting a single number here, that's no longer the case and thus breaks a lot of things.

The likely explanation for this is when a patch hits, even if just two lines are changed, the game would have to download new versions of EVERYTHING. While this meant it would get the two new lines, it also meant it would download every other line, and also re-download the "new" artwork. By breaking it into three values, now they can minimize some of the bandwidth needed to push out new updates.

This is purely an informational thread. It's closed so I can give information and you might be able to understand why you client/tool isn't working properly. Go to your appropriate tool/viewer thread to find out when it might be fixed.