Hello & Welcome to our community. Is this your first visit? Register
  • News & Announcements
      Summer event 2017 has started. Check out the patch thread for more information and discussion.
Bookmark Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Lieutenant Jiharo's Avatar
    Join Date
    Jan 2015
    Posts
    136
    Rep
    0
    Mentioned
    62 Post(s)

    Japanese character encoding

    Hi,

    May I know what happened to the character encoding? I used to be able to view Japanese text on this forum fine but after going on a hiatus for 4 months, my browser doesn't seem to recognise it anymore.

    I can read Japanese text fine on other sites like I always do, it's just this forum that has this problem.



  2. #2
    Head Moderator Kalinsre's Avatar
    Join Date
    Apr 2014
    Posts
    9,013
    Rep
    297
    Mentioned
    1552 Post(s)
    On the lower left of the forum page there is a dropdown menu. Try choosing UTF8 and see if it helps.


    1 out of 0 members found this post helpful.

  3. #3
    Lieutenant Jiharo's Avatar
    Join Date
    Jan 2015
    Posts
    136
    Rep
    0
    Mentioned
    62 Post(s)
    Quote Originally Posted by Kalinsre View Post
    On the lower left of the forum page there is a dropdown menu. Try choosing UTF8 and see if it helps.
    It doesn't. I only have 2 options: UTF-8 EN and English (US)

    What's the difference between UTF-8 EN and UTF-8? UTF-8 in the past works wonders, this UTF-8 EN doesn't.

    Also, this forum have a tendency to not register my spacebar when I quote someone. Always have to cut the quote, reload the page, and then it works normally again. Is there some kind of problem here?



  4. #4
    Head Moderator Kalinsre's Avatar
    Join Date
    Apr 2014
    Posts
    9,013
    Rep
    297
    Mentioned
    1552 Post(s)
    @Jiharo What browser are you using and what encoding are you using for the browser? Just want to gather more info on this. Thanks.



  5. #5
    Lieutenant Jiharo's Avatar
    Join Date
    Jan 2015
    Posts
    136
    Rep
    0
    Mentioned
    62 Post(s)
    Quote Originally Posted by Kalinsre View Post
    @Jiharo What browser are you using and what encoding are you using for the browser? Just want to gather more info on this. Thanks.
    Chrome.

    UTF-8, Shift-JIS, whatever that can let me read Japanese text fine on all other Japanese sites i visit.

    Also the quoting function disables the spacebar issue. Is it my browser or is there something wrong with it?



  6. #6
    Lieutenant
    Join Date
    May 2015
    Server
    Kanoya Airfield
    Posts
    147
    Rep
    10
    Mentioned
    18 Post(s)
    UTF8-EN allows the Japanese characters to show fine for me at any rate.

    Also seconding the spacebar quote issue. If the spacebar is at the end of the text, it won't work, but as long as there a character to the right of the cursor, it'll work.
    Can replicate in Chrome on both Windows and OSX.


    LSC Successes: Maruyu 23/6/15, Akitsu Maru 1/7/15, Bismarck 6/7/15, Taihou 10/9/15
    LSC Failure Count: 23

  7. #7
    Captain kazenorin's Avatar
    Join Date
    Feb 2016
    IGN
    かぜばね
    Server
    Hashirajima Anchorage
    Posts
    609
    Rep
    1
    Mentioned
    141 Post(s)
    @Jiharo

    I suspect this is a forum setting.

    Scroll to the bottom of a page on this forum (like this current page you're viewing).

    On the lower left hand corner and above the credits and version stuff, you should see the theme you're currently using (Silent Blue should be the default) and the current forum encoding (English US and UTF-8EN to choose from)

    Choose UTF-8EN and it should work fine.

    To moderators and admin:
    I suggest removing the English US option altogether to avoid confusions, since UTF8-EN should support just about everything.


    Got stuck and cannot proceed, then you, my first battleship passionately came: Kongou 126/155, 2016-02-28
    LSC Journey | Taihou 2016-06-16 | Yamato 2016-09-03 | Musashi 2016-09-08 | Bismarck 2016-09-10

  8. #8
    Lieutenant Jiharo's Avatar
    Join Date
    Jan 2015
    Posts
    136
    Rep
    0
    Mentioned
    62 Post(s)
    Quote Originally Posted by kazenorin View Post
    @Jiharo

    I suspect this is a forum setting.

    Scroll to the bottom of a page on this forum (like this current page you're viewing).

    On the lower left hand corner and above the credits and version stuff, you should see the theme you're currently using (Silent Blue should be the default) and the current forum encoding (English US and UTF-8EN to choose from)

    Choose UTF-8EN and it should work fine.

    To moderators and admin:
    I suggest removing the English US option altogether to avoid confusions, since UTF8-EN should support just about everything.
    I can see it already.in the forums.

    Problem is thread title that contain Japanese text is un-viewable still.



  9. #9
    Programmer chronomeister's Avatar
    Join Date
    Apr 2014
    IGN
    クロノマイスタ
    Server
    Tawi Tawi
    Posts
    17,561
    Rep
    206
    Mentioned
    2340 Post(s)
    Quote Originally Posted by kazenorin View Post
    To moderators and admin:
    I suggest removing the English US option altogether to avoid confusions, since UTF8-EN should support just about everything.
    I investigated this option. However, if your setting was on English US and I removed the English US option, you would be permanently stuck on English US and you would be unable to switch over to the correct one.


    Quote Originally Posted by Ilya Bryzgalov
    it's only.. it's only game. Y U heff 2 B mad?
    Quote Originally Posted by Herm Edwards

  10. #10
    Vice-Admiral Slartibartfast's Avatar
    Join Date
    Dec 2015
    Server
    Hashirajima
    Posts
    3,097
    Rep
    3
    Mentioned
    1653 Post(s)
    It's one line of code to force the cookie value switch... need me to write it?


    0 out of 1 members found this post helpful.


 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT. The time now is 02:12 PM.
Powered by vBulletin® Version 4.2.2
Copyright © 2017 vBulletin Solutions, Inc. All rights reserved.
Resources saved on this page: MySQL 6.45%
vBulletin Optimisation provided by vB Optimise v2.6.3 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Thread / Post Bookmarks provided by Thread / Post Bookmarking v1.1.1pl1 (Free) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Live Threads provided by AJAX Threads (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBulletin Skin By: PurevB.com